Author Topic: Troubleshooting Blu ray / TV  (Read 209 times)

Offline Bill

  • Universal Moderator
  • xTreme Super Poaster
  • *****
  • Posts: 6182
Troubleshooting Blu ray / TV
« on: Feb 01, 2019, 03:59 PM »
I have an odd situation. Last time I used the BRP it called for a firmware upgrade which I did but did not use it afterward. Yesterday I tried to play a Blu Ray and the TV switched to the right input channel but the screen remained blank.  I had lots of audio but nothing on the screen.  Remote buttons for menus or Home screen did nothing.  I replaced the HDMI between the BRP and AVR, no change. I also replaced the Remote batteries.

I bought an inexpensive LG (no wifi) and hooked it up, no video, audio worked. 
I have been through every setting I can find, no difference.

The one thing I haven't done is replace the ARC HDMI between the AVR and the TV.  The TV itself is fine and audio from AVR works fine.
TV is on HDMI one and BDP is on HDMI three (ARC).  I ordered a Mono Price HDMI, arriving Sunday.  Walmart only local source is loaded with poor choice cables.
Any thoughts??
EDIT: I also reset the BRP and pulled the plug on the AVR for 5 minutes.  I could not find an alternative way to reset it.
« Last Edit: Feb 02, 2019, 10:19 AM by Bill »
Fractal Design R5 | Asus  Z170 Pro | Intel i5 6600k | 16 GB G.Skill Ripjaws  DDR4 2133 | Seasonic 650w PSU | eVGA GTX 550 TI | Samsung 960 M2 500 GB | Samsung 850 EVO 500 GB | ASUS Burner | Windows 7 64-bit

Offline scuzzy

  • Forum Cop
  • Administrator
  • xTreme Super Poaster
  • *****
  • Posts: 9417
  • In an emergency, 9-1-1 calls me.
Re: Troubleshooting Blu ray / TV
« Reply #1 on: Feb 02, 2019, 11:13 AM »
I unfortunately have very few, if any, useful ideas. It seems you've already tried everything I might have. The only thing I can think of is to maybe switch cables around to see if that makes any difference at all. For example, switch out cables between the BRP and the AVR, and the cable between the AVR and the TV.

Beyond that, I have nothing.

Offline Bill

  • Universal Moderator
  • xTreme Super Poaster
  • *****
  • Posts: 6182
Re: Troubleshooting Blu ray / TV
« Reply #2 on: Feb 02, 2019, 11:15 AM »
Thanks. New cable arrives tomorrow for AVR.  Should serve the same purpose as switching existing ones around.  I will let you know.

EDIT: I have posted this problem on the AVS forum with my fingers crossed.
« Last Edit: Feb 02, 2019, 04:21 PM by Bill »
Fractal Design R5 | Asus  Z170 Pro | Intel i5 6600k | 16 GB G.Skill Ripjaws  DDR4 2133 | Seasonic 650w PSU | eVGA GTX 550 TI | Samsung 960 M2 500 GB | Samsung 850 EVO 500 GB | ASUS Burner | Windows 7 64-bit

Offline Bill

  • Universal Moderator
  • xTreme Super Poaster
  • *****
  • Posts: 6182
Re: Troubleshooting Blu ray / TV
« Reply #3 on: Feb 03, 2019, 03:23 PM »
No real help from AVS forum. I have replaced all the cables, rechecked and reseated all connections, no joy.  I am going to return it via Amazon repair, covered under warranty.
2019 has not been a good year so far.
Fractal Design R5 | Asus  Z170 Pro | Intel i5 6600k | 16 GB G.Skill Ripjaws  DDR4 2133 | Seasonic 650w PSU | eVGA GTX 550 TI | Samsung 960 M2 500 GB | Samsung 850 EVO 500 GB | ASUS Burner | Windows 7 64-bit

Offline scuzzy

  • Forum Cop
  • Administrator
  • xTreme Super Poaster
  • *****
  • Posts: 9417
  • In an emergency, 9-1-1 calls me.
Re: Troubleshooting Blu ray / TV
« Reply #4 on: Feb 03, 2019, 08:41 PM »
I'm sorry, buddy. I wish I had some advice for you, but I'm at a total loss as for what the problem might be.

Offline Bill

  • Universal Moderator
  • xTreme Super Poaster
  • *****
  • Posts: 6182
Re: Troubleshooting Blu ray / TV
« Reply #5 on: Feb 04, 2019, 10:08 AM »
Thanks, I appreciate your efforts and support.
Fractal Design R5 | Asus  Z170 Pro | Intel i5 6600k | 16 GB G.Skill Ripjaws  DDR4 2133 | Seasonic 650w PSU | eVGA GTX 550 TI | Samsung 960 M2 500 GB | Samsung 850 EVO 500 GB | ASUS Burner | Windows 7 64-bit

Offline Bill

  • Universal Moderator
  • xTreme Super Poaster
  • *****
  • Posts: 6182
Re: Troubleshooting Blu ray / TV
« Reply #6 on: Feb 04, 2019, 02:15 PM »
We have a solution. George suggested plugging the BRP into an available HDMI port on the TV, and it WORKED!!  The ARC channel picked up the sound instantly and all is well with the world, again.

And to top matters off, we had the .357 S Shield out to the range this morning with some new loads and it performed very well.
Fractal Design R5 | Asus  Z170 Pro | Intel i5 6600k | 16 GB G.Skill Ripjaws  DDR4 2133 | Seasonic 650w PSU | eVGA GTX 550 TI | Samsung 960 M2 500 GB | Samsung 850 EVO 500 GB | ASUS Burner | Windows 7 64-bit

Offline scuzzy

  • Forum Cop
  • Administrator
  • xTreme Super Poaster
  • *****
  • Posts: 9417
  • In an emergency, 9-1-1 calls me.
Re: Troubleshooting Blu ray / TV
« Reply #7 on: Feb 04, 2019, 02:17 PM »
Awesome! That's great news. I'm glad it's worked out.