Author Topic: Router -again  (Read 65 times)

Offline Bill

  • Universal Moderator
  • xTreme Super Poaster
  • *****
  • Posts: 6486
Router -again
« on: Jun 15, 2020, 08:28 hrs »
Yesterday afternoon. I update the software on my ASUS router, seemingly without issue.  Phone connected immediately but TV did not.  Last night I spent almost an hour trying to diagnose my connection problem.  TV stumbled over first picking a saved network and then the password.  Didn't seem to matter what I did. Naturally I opened the router to confirm the the password, to no avail.  I even rebooted the router, which did nothing.
No prime or Netflix, gurrrrrrrrrr.

Any suggestions?  I looked at the router, I didn't see an option to roll back the firmware.
Fractal Design R5 | Asus  Z170 Pro | Intel i5 6600k | 16 GB G.Skill Ripjaws  DDR4 2133 | Seasonic 650w PSU | eVGA GTX 550 TI | Samsung 960 M2 500 GB | Samsung 850 EVO 500 GB | ASUS Burner | Windows 7 64-bit

Online scuzzy

  • Forum Cop
  • Administrator
  • xTreme Super Poaster
  • *****
  • Posts: 9732
  • In an emergency, 9-1-1 calls me.
Re: Router -again
« Reply #1 on: Jun 15, 2020, 08:45 hrs »
You have the RT-AC1900 right? Go to ASUS site and manually download the firmware you want: https://www.asus.com/Networking/RT-AC1900/HelpDesk_BIOS/

Note that you'll have to click "Expand all" or "Show all" (make sure you're in the "BIOS & Firmware" section).

If your model is different, I'm sure you can figure out how to maneuver through the site to the right one.

I hope this helps you to get it resolved.

Offline Bill

  • Universal Moderator
  • xTreme Super Poaster
  • *****
  • Posts: 6486
Re: Router -again
« Reply #2 on: Jun 15, 2020, 09:42 hrs »
Problem solved.  The one thing I didn't do last night was reboot the TV.  I just did that and reentered the password and it connected.   Netflix and Prime are back.  Thanks for your effort.
Fractal Design R5 | Asus  Z170 Pro | Intel i5 6600k | 16 GB G.Skill Ripjaws  DDR4 2133 | Seasonic 650w PSU | eVGA GTX 550 TI | Samsung 960 M2 500 GB | Samsung 850 EVO 500 GB | ASUS Burner | Windows 7 64-bit

Online scuzzy

  • Forum Cop
  • Administrator
  • xTreme Super Poaster
  • *****
  • Posts: 9732
  • In an emergency, 9-1-1 calls me.
Re: Router -again
« Reply #3 on: Jun 15, 2020, 10:13 hrs »
Awesome! That's good news, and I would not have thought of that. I have to save that solution in my memory banks. Lol